Friday 12 September 2014

HOWTO: Dual-SIM Cisco 819 Router Config

In the hope that it helps others, here is a working config from a dual-SIM Cisco 819 router.  Not clever, just a basic working config to get you started.
!
! This config is for a Cisco 819 router with 2 SIM cards from different carriers.
! Default to primary SIM, failover to secondary SIM.
!
! For bonus points, it ought to be possible to set the GigE port

! as the primary WAN link, and set up an IP SLA to fail over to the
! cellular interface when the primary WAN link fails.
!
! The SIM-card-related config is done from the IOS command line,

! not from "config" mode.
! To set up new SIM cards, log in to the router over SSH, 

! go into Enable mode, then type something like this:-
!    cellular 0 lte profile create 4 three.co.uk        ! for 3 UK
!    cellular 0 lte profile create 5 internet        ! for Manx Telecom
! Some networks don't care what APN you set, so you might not need that.

! The router will bring up the internet link on the primary SIM.
! It should fail over to the second SIM if the first one loses coverage.
! Failover timer is set to 3 minutes in the config. 
! When testing, bear in mind that it can take a few minutes for a cellular radio
! to scan round the different frequencies before it finds the right networks.
!
! I could only test failover by powering up with the 1st SIM removed.

!
! Last configuration change at 21:46:24 UTC Mon Aug 4 2014 by cisco
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router819
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
! enable secret 5
enable password Password456
!
no aaa new-model
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 10.50.100.1 10.50.100.199
!
ip dhcp pool lan-client-pool
 network 10.50.100.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4
 default-router 10.50.100.1
 lease 7
!
ip domain name router.router
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!        
!
! license udi pid C819HG-4G-G-K9 sn
!
username FatController privilege 15 password 0 Password123
!
controller Cellular 0
 lte sim profile 4 ims 4 slot 0
 lte sim profile 5 ims 5 slot 1
 lte sim max-retry 65535
 lte failovertimer 3
!
ip ssh version 2
!
interface Cellular0
 ip address negotiated
 ip nat outside
 encapsulation slip
 dialer in-band
 dialer pool-member 1
 dialer-group 1
 async mode interactive
 routing dynamic
!
interface FastEthernet0
 switchport access vlan 100
 no ip address
!
interface FastEthernet1
 switchport access vlan 100
 no ip address
!
interface FastEthernet2
 switchport access vlan 100
 no ip address
!
interface FastEthernet3
 switchport access vlan 100
 no ip address
!
interface GigabitEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0
 no ip address
 shutdown
 clock rate 2000000
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.50.100.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer1
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer pool 1
 dialer idle-timeout 0
 dialer string lte
 dialer persistent
 dialer-group 1
!
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list MyNAT interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list standard MGMT_ACCESS
 permit 10.50.100.0 0.0.0.255
ip access-list standard MyNAT
 permit 10.50.100.0 0.0.0.255
!        
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!

line con 0
 script dialer lte
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line 3
 script dialer lte
 modem InOut
 no exec
 transport input all
 transport output all
 rxspeed 236800
 txspeed 118000
line vty 0 4
 access-class MGMT_ACCESS in
 privilege level 15
 password Password123
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

2 comments:

  1. Hi,

    Is it possible to configure Two APNs on 819 router simultaneous on each SIM?

    Thanks

    ReplyDelete
  2. @Omar: The config given above sets a different APN for each SIM. If you mean: can you set two APNs x two SIMs, then I have no idea what that would mean, or whether it's possible.

    ReplyDelete

Spammers: please stop wasting my time. All comments are moderated before publication.