Tuesday, 22 May 2012

Fix for unwanted subtitles on Humax FreeSat HD recorder

The otherwise brilliant Humax FreeSat HD recorder - the FoxSat-HDR - sometimes starts displaying subtitles that can't be turned off with the Subtitle button on the remote control.  To turn off those annoying subtitles, press the OK button twice.  I have no idea why that works, but it does.

UPDATE: you might want to try pressing EXIT first (see comments below), as pressing "OK OK" sometimes advances you to the current time, if you're watching live TV in delayed mode - which is generally when the subtitles seem to appear for no obvious reason.

15 comments:

  1. Pressing exit also works.

    ReplyDelete
  2. Ah, thanks... EXIT is better because OK OK has the side-effect of moving forward to the present time, if you're watching in delayed mode (after pausing and resuming a programme).

    ReplyDelete
  3. Great tip, this been driving us mad for yonks.

    ReplyDelete
  4. Hitting ok twice worked like a charm for me! I'm using a humax foxsat HDR.

    ReplyDelete
  5. Thank You so much. Our TV puts subtitles when we are watching in delayed time. This works amazingly.

    ReplyDelete
  6. Thank u, Thank u, Thank u! Pressed EXIT and they went away instantly :)

    ReplyDelete
  7. Worked for us too. Thanks

    ReplyDelete
  8. Yes at last I have put up with this for months...until now and I thought...Google it and voila here I am reading this and it worked a TREAT...! Very Happy :-)

    ReplyDelete
  9. Of course it would be much simpler if Humax just made a box that wasn't riddled with unwanted bugs in the first place, but hey ho. Pressing exit worked for us, too, Many thanks

    ReplyDelete
  10. Life saver. Exit worked for me. The silver lining is that, while trying to find a fix I now know the menu of the machine inside out now.

    ReplyDelete
  11. Why didn't I look sooner! I've been compromising by hitting the Information button to cover the subtitles because they were too distracting. Cheers

    ReplyDelete
  12. Humax have known the fault for ages. Thanks,Exit works fine but why didn't they tell me that when I rang them. instead they advised me to return the box to the factory settings. they should have fixed the fault long ago or sent a notice out and saved me several years of frustration.

    ReplyDelete
  13. We just tried the SUB button on the lower left side of the remote... and after 1 week it worked, we were looking for something 'more complicated'! Duh... :-) at least we can watch Christmas without Subs!

    ReplyDelete
    Replies
    1. Doesn't work for me: says something like "Not allowed in this mode". I tend to be watching live TV in delayed mode. EXIT or OK OK seems to work in that context.

      Delete

Spammers: please stop wasting my time. All comments are moderated before publication.